Форум
Написать нам
  • Страница 1 из 1
  • 1
Модератор форума: as-master  
Форум MMB » Всё о программе Multimedia Builder » Аудио и видео в MMB » FULLSCREEN
FULLSCREEN
АлександрВалерьевичДата: Пятница, 17 Апреля 2009, 21:53 | Сообщение # 1
Новый участник
Группа: Пользователи
Сообщений: 2
Репутация: 0
Награды: 0
Статус: Offline
Здравствуйте, уважаемые жители форума. С недавних пор увлекся программой ММВ и решил начать работу с видеоплеера, благо материала много. Но в ходе разработки столкнулся с такой проблемой. По окончании видео и воспроизведения нового ролика в режиме FULLSCREEN, происходит моргание, то есть сброс режима и мгновенное его восстановление. Подскажите пожалуйста можно ли решить эту проблему, чтобы смена роликов проходила гладко.Заранее спасибо. Черновик прилагаю.
ЗЫ Чтобы не создавать новую тему хочу спросить, есть ли команда для объекта флеш, что бы он отображался на весь экран(в режиме FULLSCREEN).

Добавлено (17 Апрель 2009, 21:52)
---------------------------------------------
А где все? :(

Добавлено (17 Апрель 2009, 21:53)
---------------------------------------------
Тук-тук. :(

Прикрепления: videopls.mbd(47.3 Kb)


AV
 
toizyДата: Пятница, 17 Апреля 2009, 22:02 | Сообщение # 2
Студийная субстанция
Группа: Администраторы
Сообщений: 2309
Репутация: 29
Награды: 12
Статус: Offline
Хоть убей, не вижу кнопки "фулскрин"... Колись... Как ты его делаешь?

Добавлено (17 Апрель 2009, 22:02)
---------------------------------------------
Ой.. ой.. ойойой! Что там в скрипте-то творица!

Вейт э сек...


Жизнь оказалась не такой уж и забавной, как поначалу...
 
PeterДата: Пятница, 17 Апреля 2009, 22:32 | Сообщение # 3
Админ NeoBook
Группа: Админ NeoBook
Сообщений: 1265
Репутация: 75
Награды: 18
Статус: Offline
Заинтриговал вопрос:
Quote (toizy)
Колись... Как ты его делаешь?

Скачал проект, запустил, но..
У меня нифига не работает: звук есть, а вот видео....
Искал.. Искал...
Не нашел... :'(

Добавлено (17 Апрель 2009, 22:30)
---------------------------------------------
А вот в WMV-формате картинка появилась, но... не во весь экран.. :(

Добавлено (17 Апрель 2009, 22:32)
---------------------------------------------
Может это у меня какие глюки на компе?


Никто не может вернуться в прошлое и изменить свой старт.
Но каждый может стартовать сейчас и изменить свой финиш!
 
toizyДата: Пятница, 17 Апреля 2009, 22:59 | Сообщение # 4
Студийная субстанция
Группа: Администраторы
Сообщений: 2309
Репутация: 29
Награды: 12
Статус: Offline
Ещё бы.. И будет моргать, ведь ты устанавливаешь фулскрин ПОСЛЕ того, как отыграет весь плейлист. И с командами путаница.. А если используешь фулскрин, то зачем ресайзишь объект видео тогда? Потом, конструкцию вида

ListBoxAdditem("SongList", "<List>NumInList")

вообще не понял %)

Короче, смотри исправленный вариант

Добавлено (17 Апрель 2009, 22:59)
---------------------------------------------
глюки были в скриптах. Культ Copy-Paste в действии

Прикрепления: 8987774.mbd(42.4 Kb)


Жизнь оказалась не такой уж и забавной, как поначалу...
 
АлександрВалерьевичДата: Вторник, 21 Апреля 2009, 12:08 | Сообщение # 5
Новый участник
Группа: Пользователи
Сообщений: 2
Репутация: 0
Награды: 0
Статус: Offline
Спасибо за исправленный пример. Но извини, не могу понять для чего он был сделал. Разуметься мой вариант грубый и не исправленный, ведь это только черновик. Но в моем примере после загрузки видео файлов, первый файл и последующие запускаться автоматом (как музыка в мр3 плеерах ), но в фуллскрин режиме после показа ролика, режим слетает и тут же запускается со следующим роликом. Команду VideoParam("Video","FULLSCREEN = ON") куда я только не пристраивал и все равно между роликами происходит моргания. К сожалению в твоем примере, видео запускаться только по клику мышкой в плейлисте и следующий ролик то же нужно запускать в ручную, соответствен пример проблемы не решает. Так что вопрос плавного перехода видео в полноэкранном режиме остается открытый!

Добавлено (21 Апрель 2009, 12:08)
---------------------------------------------

Quote (Peter)
А вот в WMV-формате картинка появилась, но... не во весь экран.. :(

Добавлено (17 Апрель 2009, 22:32)
---------------------------------------------
Может это у меня какие глюки на компе?

MMB в принципе может поддерживать любой видео формат при наличии сторонних кодеков и указанных в скриптах соответствующих расширений. У меня тоже были глюки с видео, но недавно поставил VistaCodecs и пролемы больше нет, если в фильтрах я ставлю расширение FLV, то плеер соответственно его и воспроизводить. Кстати кодек у меня нормально робит как Висте так и на XP. K-Lite как бы его не хвалили, ставить не рекомендую так как проблема конфликтов там до сих пор не решена.


AV
 
toizyДата: Вторник, 21 Апреля 2009, 13:20 | Сообщение # 6
Студийная субстанция
Группа: Администраторы
Сообщений: 2309
Репутация: 29
Награды: 12
Статус: Offline
Quote (АлександрВалерьевич)
режим слетает и тут же запускается со следующим роликом.

Блин, я тоже хорош... Не то тебе понаписал... Щас...


Жизнь оказалась не такой уж и забавной, как поначалу...
 
toizyДата: Вторник, 21 Апреля 2009, 16:00 | Сообщение # 7
Студийная субстанция
Группа: Администраторы
Сообщений: 2309
Репутация: 29
Награды: 12
Статус: Offline
Вылезла трабла определённого свойства... Смотрите прикрепление. Может, кто-то догадается, почему проигрывается только первый файл? или я уже туплю?
Прикрепления: 0974907.mbd(42.7 Kb)


Жизнь оказалась не такой уж и забавной, как поначалу...
 
Форум MMB » Всё о программе Multimedia Builder » Аудио и видео в MMB » FULLSCREEN
  • Страница 1 из 1
  • 1
Поиск: